WordPress 5.0 ¿Cuando es el mejor momento para actualizar?

WordPress 5.0

WordPress 5.0 sale hoy, 6 de Diciembre de 2018, fiesta en España y en gran parte de Europa, por lo que a más de uno le va a pillar de sorpresa esta actualización mayor.

Y decimos mayor porque integra definitivamente el polémico nuevo editor Gutenberg.

Si no sabes muy bien de que va esto de Gutenberg te recomiendo que leas algunos de nuestros post al respecto.

Y decimos polémico porque han corrido ríos de tinta y debates a lo largo de toda la WordPressfera, comunidad, post, WordCamps, Meetups sobre lo bueno y lo malo de Gutenberg.

Gutenberg es un gran salto para WordPress, es el nuevo editor de bloques que viene a sustituir al hasta ahora editor clásico, más visual, más organizado, más opciones y con una serie de herramientas que en un principio ayudan a la hora de crear y editar nuestros post pero que necesita un aprendizaje y adaptación.

Uno de los grandes inconvenientes de Gutenberg, es que ha obligado a la mayoría de desarrolladores de plugins y themes, a adaptar sus productos para que sean compatibles con Gutenberg y no todos se han adaptado, de hecho, hoy mismo, seguramente estás recibiendo emails de actualizaciones de plugins y themes, en los que su principal cambio, es que sean compatibles con Gutenberg.

Los desarrolladores mas populares e importantes, ya están distribuyendo sus productos con los cambios necesarios para que sean compatibles con WordPress 5.0 y en especial con Gutenberg.

El problema, es que hay miles de plugins y miles de themes y no todos se están adaptando, especialmente los que son muy antiguos, están prácticamente abandonados y no se espera de ellos ninguna actualización para la compatibilidad con Gutenberg e internet está lleno de WordPress con estos plugins y themes, que llevan mucho tiempo sin actualizarse, que por el momento funcionan pero que ahora, es muy posible que dejen de funcionar y lleven al traste miles de páginas webs desarrolladas con WordPress.

Importante decir, que esta actualización es una actualización mayor y por tanto, no es automática, hay que hacerla manualmente, por lo que a priori no debemos temer por ello.

Igualmente, si decides actualizar a WordPress 5.0, te recomendamos que antes, instales el editor clásico a modo plugin, tal y como explicamos en nuestro post

Al instalar el editor clásico, este será tu editor por defecto y “bloqueará” a Gutenberg, esto te dará tiempo a comprobar que acciones debes tomar y siempre puedes pasar del editor clásico al Gutenberg y vice versa, por lo que esto no debe ser un problema, Gutenberg, en un principio no romperá la edición original de tus post.

Pero…. y siempre hay un pero, es muy posible que alguno de tus plugins y themes no sean compatibles con Gutenberg y esto si puede ser el verdadero problema, que tu web se rompa.

Por eso es muy importante que chequees con los desarrolladores de tus plugins y themes, que estos son compatibles, los que sean del repositorio de WordPress, dispones de sus fichas técnicas y foros de soporte, los que sean de pago, dispondrán de su web o forma de contactar con ellos para asegurarnos que son compatibles.

Pero cuando es el mejor momento para actualizar.

En un principio, no es una actualización de seguridad, por lo que podemos esperar a actualizar, mis recomendaciones son las siguientes:

  • Instala el editor clásico como plugin, para que sea el editor por defecto por delante de Gutenberg.
  • Asegúrate de que tus plugins y themes son compatibles y que están actualizados.
  • Antes de actualizar, haz una copia de seguridad o dos.
  • Si tu proveedor de hosting te proporciona actualizaciones automáticas, desactívalas de momento.
  • Haz entornos de prueba, clones, staging, para saber con certeza que nada se romperá.
  • Ponte al día visitando blogs, foros, repositorio de WordPress y otros para conocer la experiencia de otros usuarios.
  • Si te han desarrollado tu web otra persona, empresa, agencia o te llevan el mantenimiento, contacta con ellos y asegúrate que tienen el tema controlado.
  • El orden de actualización, primero themes, plugins y por último WordPress.

Lo mejor es ser prudente, asegurarnos que todo va a funcionar bien, que todo sea compatible, que tenemos la información, que tenemos copias de seguridad.

A partir de ahí, cuando ya sabemos que todo va a ir bien, que todos nuestros plugins y themes son compatibles, podemos actualizar sin problema, pero siempre, tomando las precauciones mencionadas anteriormente.

Nosotros, seguiremos informando a través de nuestro blog y Redes Sociales, puedes seguirnos en @hostfusion, en nuestra página oficial de Facebook y en nuestro grupo de Seguridad WordPress donde debatimos sobre este tema y por supuesto sobre seguridad WordPress.